420 Magazine Background

Help help

mustang671

New Member
Someone please tell me what I'm doing wrong. I cant clone too save my life. I'm doing everything right or so I thought. Ive followed Cervantes instructions every step of the way or so I thought! The only thing I didn't do was use distilled water, could that be it? I have had successful crops for more that 5 years now all indoor and at a rate of around 75 to 100 per harvest wont say how many harvest I get per year for obvious reasons. I grow from seeds always feminized I have friends that bring me sick plants that I can always nurse back to health. I consider myself to have a green thumb. My temps climate humidity hps and mh lights are all in order. I use a t-5 fluoro chained about 2-3 inches off the clones witch should be perfect. I just don't get it I cant clone. :cheer:
 

Hightide805

New Member
Cervantes suggests a few different ways, what are you using for your medium?

I follow Jorge's way and use soil, and have a pretty good return, they don't always make it, it depends on the strian as well, some are harder to clone.
 

dirty420247

New Member
My first attempt at cloning went awry also, I later found out air embolisms were the cause of my woes. If any air gets into the cutting then it will kill the clone. If you aren't dipping the cutting in the rooting solution immediately after cutting it that may be your problem.
 

mustang671

New Member
Thank you all! Fixed the prob it was the PH in my distilled water over 8 I dropped it to 5.2 to 5.5 and my clones are thriving I cant believe I over looked the most basic thing.
 
Top Bottom