420 Magazine Background

What am I doing wrong?

CrunchieGreen

New Member
Hey 420,

I recently germinated some white widow x big bud seed and placed them in rockwool then once sprouted into ym dwc set up.
They seem to be growing really slow, I had the same problem with my last bag seeds.

I don't know what I'm dojng wrong everything seems good.

Lights: 2 x 125w Cfl placed 5-6 inchs away. 20/4
Cab temp: 75-80
Water temp: 65-75
Water is about an inch under the pots, it was over the pots bottom and the rockwool seems a bit wet so I'm concerned I over watered.
Nutes: rhizotonics 20ml into 18L of water.. no signes of nute burn.
Fan is softly blowing over them.

Any thoughts ?
 

labexperiment

Well-Known Member
Re: What am I doing wrong.

Pics almost always help.
First confirm the roots are in the water and the air stone is directly under the pot and the roots are getting air. Rhizotonic is a stimulator and not considered nutrients in and of themselves, you may need to add some diluted nutrients to you DWC, start with 1/8 strength nutrients or weaker if you do not have the third set of true leaves showing yet. I would also recommend going to 5.5 hours of dark for their sleeping needs.
Let us know if this helps. Good luck.
 

CrunchieGreen

New Member
Re: What am I doing wrong.

Cheers labex, they have only started to grow there second set of leaves, the first set are still small. It's been roughly 2 weeks from sprout, Iv compared them to other dwc grows and by this time they have at least 3 decent sets of leaves and in the last week Iv seen no progress at all.

The stones are directly under the pots, they are only 20L buckets so just about anywhere the stone sits they will be getting bubbles.
I'm going to switch to 18/6 when I pick up a timer tonight. I'll also get some pics up.
I'll give them till the weekend then add weak nutes and see how they like it.

Thanks again.
 

CrunchieGreen

New Member
Re: What am I doing wrong.

Only photo I have at the moment. Will get a better one.

IMAG018321.jpg
 

devils letuce

Well-Known Member
Re: What am I doing wrong.

i just started a ww/bb and its the slowest growing plant i have so far .. which sucks because the nl/bb was a fast vibrant plant that loooved to eat .
 
Top Bottom