420 Magazine Background

Hello everyone to one amazing community

BeanTownFan420

Well-Known Member
Hi,

As you all know, Im on the 2nd try growing. Everything was going well till now.
Spots are appearing on the leaves again, as per attached photo.

Im in the 3rd week of flowering. PH 5.8 and ppm at 900.

Do you know why its always keep happening with my grows or what i can do ?

Im using canna products and feeding them light feeding.
Also im using ro water starting at 120 ppm than adding cal mag to get at 400pm.
Then i start adding nuts.
I have a 400w bulb and is 1 foot away.Temperatures are at 22deg
Now just raised the bulb to2 feet away.

ANY THOUGHTS MATES ??
Calcium lock out!
 

Emilya

Well-Known Member
Sadly I agree... that sure looks like spider mite damage. Look at the trunk of that plant, between the soil and the first node. Look for little tiny moving black spots. Look carefully for any webs down in those lower notches. Get some Safer's End All or some other effective mite control product... it is good to have some in the grow room just in case anyway. Get those things under control fast or they will take over the whole room.
 

Mr gar

Active Member
no mites if you look at my previous pics of my last grow i had the same problem but at an earlier stage then this ... no mites or bugs of any sorts ... i am thinking some kind of deficiency or light was too close .... i am worried now as itcan get much worse only on the top of some of the leafs i am having this problem
 

Mr gar

Active Member
Sadly I agree... that sure looks like spider mite damage. Look at the trunk of that plant, between the soil and the first node. Look for little tiny moving black spots. Look carefully for any webs down in those lower notches. Get some Safer's End All or some other effective mite control product... it is good to have some in the grow room just in case anyway. Get those things under control fast or they will take over the whole room.
i have canna cure also but never seen any mites under the mag glass
 

BeanTownFan420

Well-Known Member
I promise.
Hi,

As you all know, Im on the 2nd try growing. Everything was going well till now.
Spots are appearing on the leaves again, as per attached photo.

Im in the 3rd week of flowering. PH 5.8 and ppm at 900.

Do you know why its always keep happening with my grows or what i can do ?

Im using canna products and feeding them light feeding.
Also im using ro water starting at 120 ppm than adding cal mag to get at 400pm.
Then i start adding nuts.
I have a 400w bulb and is 1 foot away.Temperatures are at 22deg
Now just raised the bulb to2 feet away.

ANY THOUGHTS MATES ??
Calcium issue..PNG
Calcium issue..PNG
 

Emilya

Well-Known Member
Im almost never wrong nor do i ever kill a plant after i diagnose it i fix it.
BTF, on second look I agree with you, there is also a bit of a magnesium deficiency going on. But other than that, I have never seen anything other than spider mites that can make those little pinprick white spots on leaves. The little critters are dang near impossible to see, but somewhere in that room is a nest of them.
 

BeanTownFan420

Well-Known Member
Now if you get red dust on your plants then your going the way of the do do bird that means you got Hemp russet the worst thing to happen to cannabis since prohibition we can thank hemp for that.
 

Emilya

Well-Known Member
I only got them once, and i will never repeat the mistake of bringing plants into my garden from outside. It took me a while to get them out of the grow room and I suffered with them through parts of 2 grows. They are horrible little critters and they must be dealt with quickly and effectively.
 

BeanTownFan420

Well-Known Member
Bugs are why i abandoned cloning for the most part plus legalization made seed a much better option for that one reason clean start over bug free.
 

Emilya

Well-Known Member
are you putting in the recommended amount of calmag? How long have you been adding it?
 

BeanTownFan420

Well-Known Member
Frost is the key when it comes to mites it kills them thats why winter indoor growing can be our best friend its a bug and mold free time of year.
 

Mr gar

Active Member
Was adding Cal mag as recommend but wasn't always topping it off when I to it off in a daily basis .. for eg ... I do a water change today and the next day I add 2 ltrs and the next and then after the 3 time I add I start to top it off with Cal mag .. I think there is where I went wrong !! . Can I fix this problem now ? I just added another 2 ml now of Cal mag . Tomorrow I will do a water change . Any tips please ? Gooing to bed now it's 2 am have to go to work at 6 am . Will check your reputation in the morning . Thanks you guys I will leave you a reply back soon as I wake up
 

BeanTownFan420

Well-Known Member
Yes i have had plants fifth week of flower get cal mag issue and tiger bloom always fixes it within 3 days after flushing salts and adding tiger bloom.
 
Top Bottom